Connectivity issues (Upstream, Cloudflare)
Incident Report for XRPL Labs, XUMM
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 15:42 CEST
Update
We are continuing to monitor for any further issues.
Posted Jun 21, 2022 - 10:12 CEST
Update
Our platform is back at ~70% of normal traffic. We're closely monitoring the situation, but for most users services seem to have been restored.
Posted Jun 21, 2022 - 09:14 CEST
Monitoring
The first reports are coming in from users being able to connect to our public XRP Ledger infrastructure & the Xumm services again. While Cloudflare is rolling out their fix, services will be restored for more users.

For those still not being able to connect to Cloudflare infrastructure, Xumm may still have trouble connecting to the Xumm backend, resulting in xApp icons, xApps & sign requests not loading.
Posted Jun 21, 2022 - 09:07 CEST
Update
Cloudflare reported on their status page:

"The issue has been identified and a fix is being implemented."
https://www.cloudflarestatus.com/incidents/xvs51y9qs9dj
Posted Jun 21, 2022 - 08:59 CEST
Update
The XRP Ledger is working, closing ledgers & not having any issues: XRPL nodes & validators are peering directly (without relying on Cloudflare).

Public node reachability (for e.g. transaction information, etc.) is affected (but everything will be available retroactively).
Posted Jun 21, 2022 - 08:52 CEST
Identified
Like most platforms & services, the Xumm platform (xApps, price information, sign requests) & XRPLCluster.com rely on Cloudflare.

Cloudflare has a major global outage.

Cloudflare is investigating wide-spread issues with our services and/or network. Users may experience errors or timeouts reaching Cloudflare’s network or services.

Cloudflare will update their status page (https://www.cloudflarestatus.com) to clarify the scope of impact as they continue the investigation.
Posted Jun 21, 2022 - 08:51 CEST
This incident affected: XUMM API / SDK (XUMM Developer API/SDK) and XRP Ledger - Public nodes (xrplcluster.com (XRPL Mainnet)).